CFG Deposits Delayed
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 15:45 UTC
Investigating
We are currently investigating this issue.
Posted Nov 25, 2022 - 19:27 UTC
This incident affected: Deposits.