NYM Withdrawals Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Apr 15, 2022 - 21:45 UTC
Investigating
NYM withdrawals have been temporarily disabled. Any pending withdrawals will be completed shortly. We are delaying new withdrawals while we investigate.

All funds are safe. We will update this status when we have additional information.
Posted Apr 15, 2022 - 07:45 UTC
This incident affected: Withdrawals.