CSPR Withdrawals
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Oct 02, 2021 - 14:16 PDT
Investigating
We are actively trying to fix this issue and withdrawals should be back up soon
Posted Sep 30, 2021 - 18:35 PDT
This incident affected: Withdrawals.