Re-verification Issue Impacting a Subset of Users
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 14:09 UTC
Update
Resolved
Posted Mar 05, 2024 - 14:06 UTC
Investigating
We've identified a limited outage related to KYC re-verification and withdrawals which are impacting some users. We are actively investigating this issue.
Posted Mar 01, 2024 - 20:27 UTC
This incident affected: CoinList - Website.