DOT Deposits and Withdrawals Delayed

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 09:07 UTC

Identified

Our custodian, Coinbase, has identified the issue and is actively working on a fix.
Posted Mar 21, 2025 - 13:00 UTC
This incident affected: Withdrawals and Deposits.