MINA Withdrawals Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Dec 06, 2021 - 16:54 UTC
Investigating
MINA withdrawals are disabled while we investigate an issue with our custodian partner.

Any pending MINA withdrawals will be processed as soon as possible.
Posted Dec 05, 2021 - 17:39 UTC
This incident affected: Withdrawals.