Deposits & withdrawals for DOGE, FIL, and XTZ may be delayed

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 10:16 UTC

Investigating

Our custodian is having scheduled maintenance in progress.
Posted Jun 03, 2025 - 07:55 UTC
This incident affected: Withdrawals and Deposits.