FIL, EFIL, XTZ Deposits/Withdrawals Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Nov 12, 2021 - 12:33 PST
Investigating
Gemini Custody is currently performing maintenance, as a result, we have disabled FIL, EFIL, and XTZ deposits and withdrawals until maintenance is complete. We apologize for the inconvenience.
Posted Nov 12, 2021 - 08:58 PST
This incident affected: Withdrawals and Deposits.