SUI and SQD Withdrawals Delayed
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Dec 06, 2024 - 19:47 UTC
Update
SUI Withdrawals have been fixed and are processing successfully. We are continuing to work on a fix for SQD Withdrawals.
Posted Dec 05, 2024 - 22:51 UTC
Investigating
We are currently investigating this issue.
Posted Nov 27, 2024 - 11:02 UTC
This incident affected: Withdrawals.