ICP Withdrawals Temporarily Disabled

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Apr 01, 2024 - 07:36 UTC

Investigating

We are currently investigating this issue.
Posted Mar 06, 2024 - 17:48 UTC
This incident affected: Withdrawals.