CFG, ROSE, and FLOW Deposits and Withdrawals Scheduled for Maintenance

Incident Report for CoinList

Resolved

CFG, ROSE, and FLOW Deposits and Withdrawals have been re-enabled.
Posted Mar 27, 2025 - 15:09 UTC

Investigating

Our custodian will undergo scheduled maintenance on March 27, 2025, at 8:45 AM UTC / 01:45 AM (PT). CFG, ROSE, and FLOW deposits and withdrawals will be temporarily disabled.
Posted Mar 26, 2025 - 14:36 UTC
This incident affected: Withdrawals and Deposits.