DOT, ICP and SOL deposits are delayed
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 12:47 UTC
Investigating
We are working with our custodian to resolve an issue affecting deposits for DOT, ICP, and SOL. As a result, a delay in deposits is expected.
Posted Jan 19, 2023 - 13:23 UTC
This incident affected: Deposits.