XTZ Withdrawals Disabled
Incident Report for CoinList
Update
We are continuing to investigate this issue.
Posted Sep 17, 2021 - 15:54 PDT
Investigating
XTZ Withdrawals are currently disabled. We are currently investigating with our custodian.
Posted Sep 14, 2021 - 14:35 PDT
This incident affects: Withdrawals.