Delayed ICP/SOL/DOT Withdrawals
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted May 21, 2024 - 13:57 UTC
Investigating
We are currently experiencing delays with ICP/SOL/DOT withdrawals. We are currently investigating the issue, and will update as we have more information.
Posted May 20, 2024 - 19:00 UTC
This incident affected: Withdrawals.