CELO & CUSD Deposits Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 22:03 UTC
Update
We are continuing to investigate this issue.
Posted Nov 30, 2022 - 15:42 UTC
Investigating
We are currently investigating this issue.
Posted Nov 30, 2022 - 15:41 UTC
This incident affected: Deposits.