CFG Deposits and Withdrawals Temporarily Disabled

Incident Report for CoinList

Resolved

The issue has been Resolved
Posted Jul 10, 2024 - 15:04 UTC

Investigating

We are currently investigating this issue.
Posted Jul 08, 2024 - 16:27 UTC
This incident affected: Withdrawals and Deposits.