AVAX Withdrawals Temporarily Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Jul 25, 2023 - 16:57 UTC
Investigating
We are currently investigating this issue.
Posted Jun 20, 2023 - 16:42 UTC
This incident affected: Withdrawals.