XTZ deposits and withdrawals are offline
Incident Report for CoinList
Resolved
Will provide updates to users when XTZ comes back online
Posted Apr 26, 2021 - 13:49 PDT
Monitoring
XTZ deposits and withdrawals are offline
Posted Mar 30, 2021 - 10:54 PDT