Nillion Deposits Disabled, Withdrawals are Delayed

Incident Report for CoinList

Update

Nillion deposits have been re-enabled.
Posted Mar 25, 2025 - 12:01 UTC

Update

We have temporarily disabled deposits for Nillion.
Posted Mar 24, 2025 - 14:42 UTC

Investigating

Some users may experience a delay while withdrawing Nillion. We are investigating the issue.
Posted Mar 24, 2025 - 13:57 UTC
This incident affects: Withdrawals.