WCT Withdrawals Delayed

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 13:36 UTC

Monitoring

WCT withdrawals are experiencing delays due to high volumes. We, along with our partner custodian, have been able to scale the withdrawal capacity. Withdrawal requests are being processed and should all be completed soon.
Posted Apr 15, 2025 - 16:04 UTC
This incident affected: Withdrawals.