Ongoing Custody Maintenance - FLOW, MINA, CFG, ROSE
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 19:23 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 17, 2022 - 00:15 UTC
Monitoring
**Update: November 17 00:10 UTC**

Our custody partner is undergoing maintenance that is taking longer than expected. During this time period deposits and withdrawals for FLOW, MINA, ROSE and CFG are unavailable.

Rest assured your funds are safe. We will continue to provide updates as we have them. Thank you for your patience!
Posted Nov 15, 2022 - 19:01 UTC
This incident affected: Withdrawals and Deposits.