ALGO Deposits Delayed
Incident Report for CoinList
Update
We are continuing to investigate this issue.
Posted Nov 15, 2022 - 15:34 UTC
Investigating
We are currently investigating this issue.
Posted Nov 15, 2022 - 15:34 UTC
This incident affects: Deposits.