MINA Deposits and Withdrawals Temporarily Disabled due to Maintenance.

Incident Report for CoinList

Resolved

This incident has been resolved
Posted Aug 05, 2024 - 13:33 UTC

Investigating

MINA Deposits and Withdrawals Temporarily Disabled due to Maintenance.
Posted Jul 31, 2024 - 15:52 UTC
This incident affected: Withdrawals and Deposits.