FIL Deposits and Withdrawals Temporarily Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 11:10 UTC
Investigating
We are currently investigating this issue.
Posted Dec 03, 2024 - 02:43 UTC
This incident affected: Withdrawals and Deposits.