ROSE and FLOW Vault Staking Rewards Delayed

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Dec 10, 2024 - 20:46 UTC

Update

FLOW staking rewards have been distributed.
We are still working on ROSE reward distribution.
Posted Dec 10, 2024 - 07:20 UTC

Investigating

ROSE and FLOW Vault Staking Rewards are delayed due to technical issues. Our team is working to resolve this promptly.
Posted Nov 21, 2024 - 07:28 UTC