FIL Deposits, Withdrawals, and Trading Disabled

Incident Report for CoinList

Resolved

Unscheduled maintenance for FIL has been completed. Deposits, Withdrawals, and Trading have all been enabled.
Posted Oct 10, 2025 - 03:00 UTC

Investigating

FIL Deposits, Withdrawals, and Trading are temporarily disabled for unscheduled maintenance. We apologize for any inconvenience.
Posted Oct 04, 2025 - 04:52 UTC
This incident affected: Trading, Withdrawals, and Deposits.