ETH + ERC-20 Withdrawal Delays
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 22:34 UTC
Monitoring
We're experiencing some high volume and as a result will have some delays in processing ETH + ERC-20 withdrawals
Posted Oct 04, 2021 - 18:40 UTC
This incident affected: Withdrawals.