EFI Withdrawals Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Dec 12, 2021 - 18:36 UTC
Investigating
EFI withdrawals are temporarily disabled. We are investigating the issue with our custodian partner.
Posted Dec 12, 2021 - 17:31 UTC
This incident affected: Withdrawals.