Scheduled Custodian Wallet Maintenance

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 14:01 UTC

Identified

Our custodian has started scheduled maintenance and is expected to last about 2 hours. Deposits and Withdrawals are temporarily disabled for the following assets: LBTC, WEETH, WSTETH, KING, ETHFI, NIL, Native PEAQ, MINA, USDE
Posted Mar 26, 2025 - 20:06 UTC
This incident affected: Withdrawals and Deposits.