CELO Deposits Disabled
Incident Report for CoinList
Update
We are continuing to investigate this issue.
Posted Jun 03, 2022 - 15:38 UTC
Update
We are continuing to investigate this issue.
Posted May 30, 2022 - 15:50 UTC
Update
We are continuing to investigate this issue.
Posted Mar 21, 2022 - 19:21 UTC
Update
We are continuing to investigate this issue.
Posted Feb 26, 2022 - 19:29 UTC
Update
We are continuing to investigate this issue.
Posted Feb 24, 2022 - 14:34 UTC
Investigating
CELO deposits are disabled while we investigate an issue with our custodian partner.
Posted Feb 09, 2022 - 22:57 UTC
This incident affects: Deposits.