FLOW Withdrawals Disabled

Incident Report for CoinList

Resolved

FLOW withdrawals have been re-enabled.
Posted Dec 09, 2024 - 17:52 UTC

Investigating

We are currently investigating this issue.
Posted Nov 20, 2024 - 16:47 UTC
This incident affected: Withdrawals.