ICP Withdrawals
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Oct 11, 2021 - 10:40 PDT
Monitoring
Due to high volume, we are experiencing some slowness in processing ICP withdrawals
Posted Oct 10, 2021 - 09:46 PDT
This incident affected: Withdrawals.