SEI Deposits Temporarily Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 18:41 UTC
Update
We are continuing to investigate this issue.
Posted Mar 04, 2024 - 13:16 UTC
Investigating
We are currently investigating this issue.
Posted Mar 04, 2024 - 13:15 UTC
This incident affected: Deposits.