ID Verification offline
Incident Report for CoinList
Resolved
ID verification is back online, thank you for your patience.
Posted May 03, 2021 - 02:59 PDT
Investigating
Our ID verification partner is performing scheduled maintenance from 5:00 UTC to 6:30 UTC on May 3, 2021. During this time you will not be able to complete registration on the site. We apologize for the inconvenience.
Posted May 02, 2021 - 22:00 PDT
This incident affected: CoinList - Website.