Mina CoinList.co + Mobile Trading Outage
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Jun 01, 2021 - 03:46 PDT
Investigating
Mina trading is currently down for CoinList.co and Mobile. Please use CoinList Pro if you wish to trade MINA.
Posted Jun 01, 2021 - 02:17 PDT
This incident affected: Trading.