CELO & cUSD Delayed Deposits & Withdrawals
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 13:57 PDT
Investigating
CELO and CUSD deposits and withdrawals may be delayed. We are investing the issue with our custodian.
Posted Sep 14, 2021 - 14:38 PDT
This incident affected: Withdrawals and Deposits.