ERC-20 Deposits Delayed
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted May 10, 2023 - 22:28 UTC
Investigating
We are currently investigating this issue.
Posted May 08, 2023 - 19:16 UTC
This incident affected: Deposits.