GAL Trading, Deposits and Withdrawals Disabled

Incident Report for CoinList

Resolved

Migration from GAL to G is complete.
Posted Dec 10, 2024 - 20:24 UTC

Investigating

GAL trading, deposits, and withdrawals are temporarily disabled for scheduled maintenance.
Posted Sep 09, 2024 - 18:47 UTC
This incident affected: Trading, Withdrawals, and Deposits.