FIL, eFIL, DOGE and XTZ Deposits and Withdrawals Delay

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:08 UTC

Investigating

We’re currently investigating an outage affecting parts of our platform. Some features may be slow or delayed.
Posted Oct 20, 2025 - 11:54 UTC
This incident affected: Withdrawals and Deposits.