BLD Deposits Delayed
Incident Report for CoinList
Update
We are continuing to investigate this issue.
Posted Nov 16, 2022 - 18:57 UTC
Investigating
We are currently investigating this issue.
Posted Nov 16, 2022 - 18:57 UTC
This incident affects: Deposits.