AVAX Withdrawals Temporarily Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Feb 23, 2024 - 21:20 UTC
Investigating
We are currently investigating this issue.
Posted Feb 23, 2024 - 14:25 UTC
This incident affected: Withdrawals.