Ongoing Custody Maintenance - SOL
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Dec 23, 2022 - 18:51 UTC
Update
We are continuing to investigate this issue.
Posted Dec 16, 2022 - 20:40 UTC
Update
We are continuing to investigate this issue.
Posted Dec 16, 2022 - 20:39 UTC
Investigating
Our custody partner is undergoing maintenance. During this time period deposits and withdrawals for ICP, SOL, and DOT are unavailable.

Rest assured your funds are safe. We will continue to provide updates as we have them. Thank you for your patience!
Posted Dec 08, 2022 - 16:33 UTC
This incident affected: Withdrawals and Deposits.