MINA Deposits and Withdrawals Temporarily Disabled due to Ongoing Maintenance.
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 02:04 UTC
Monitoring
As soon as maintenance is complete Deposits and Withdrawals will be re-enabled.
Posted Apr 15, 2024 - 17:19 UTC
This incident affected: Withdrawals and Deposits.