ALGO Deposits Temporarily Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Jun 15, 2023 - 15:41 UTC
Update
We are continuing to investigate this issue.
Posted Jun 08, 2023 - 16:25 UTC
Investigating
We are currently experiencing an issue impacting ALGO deposits. Our team is working to resolve the issue as quickly as possible.
Posted Jun 08, 2023 - 16:18 UTC
This incident affected: Deposits.