MINA Withdrawals Delayed

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Aug 02, 2023 - 16:52 UTC

Investigating

We are currently investigating this issue.
Posted Jul 21, 2023 - 23:29 UTC
This incident affected: Withdrawals.