SQD Trading is currently not working
Incident Report for CoinList
Resolved
Issue fixed.
Posted May 17, 2024 - 08:11 UTC
Investigating
We are currently investigating this issue.
Posted May 17, 2024 - 08:06 UTC
This incident affected: Trading.