Scheduled Maintenance - CFG and FLOW

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted May 26, 2025 - 12:44 UTC

Investigating

FINOA will undergo scheduled maintenance on Friday, May 23, 2025, from 08:30 AM to 09:30 AM (CET) / 11:30 PM to 12:30 AM (PT).
During this period, CFG and FLOW deposits and withdrawals will be temporarily disabled. Thank you for your patience.
Posted May 23, 2025 - 00:45 UTC
This incident affected: Withdrawals and Deposits.