CoinList Twitter Account
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Jul 31, 2023 - 14:00 UTC
Investigating
The @CoinList Twitter account has been hacked. Please do not click on any links. CoinList is not launching a token and we have no plans to do so. CoinList remains in control of all of our other official social media channels.

Our security team is actively investigating the situation. We will notify our community as soon as the restoration process is complete.
Posted Jul 24, 2023 - 15:23 UTC
This incident affected: CoinList - Website.