ALGO Deposits Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 13:26 UTC
Investigating
ALGO deposits are disabled while we investigate an issue with our custodian partner.
Posted Sep 13, 2022 - 21:21 UTC
This incident affected: Deposits.