MINA Withdrawals Disabled

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted 3 years ago. Mar 11, 2022 - 17:15 UTC

Identified

MINA withdrawals are temporarily disabled. We are investigating the issue with our custodian partner.
Posted 3 years ago. Mar 04, 2022 - 17:27 UTC
This incident affected: Withdrawals.